Strona tytułowa i wprowadzenie do przewodnika
Niniejszy przewodnik stanowi rozszerzenie zagadnień audytu i telemetrii omówionych w Wykładzie 6 ('Logowanie zdarzeń i bezpieczeństwo'). Przedstawia techniczne szczegóły wdrożenia produkcyjnego serwera rsyslog oraz podłączenia heterogenicznych węzłów sieciowych.
- Cel inżynierski: Zbudowanie niezawodnego repozytorium zdarzeń systemowych odpornego na awarie łączy i próby zatarcia śladów przez intruzów
- System operacyjny serwera: System Linux (Debian 12 / Ubuntu 22.04 / 24.04 LTS) z demonem rsyslog w wersji 8.x wspierającym nowoczesną składnię RainerScript
- Źródła zdarzeń: Inne stacje i serwery Linux (systemd-journald, rsyslog, bufor dyskowy) oraz urządzenia sieciowe MikroTik RouterOS (wersje v6 i v7)
- Standardy i bezpieczeństwo: Zgodność ze specyfikacjami RFC 3164, RFC 5424 (IETF Syslog), szyfrowanie TLS (RFC 5425) oraz tunelowanie VPN